Forum

Post a new question

Categories:

Tags:

installation under Ubuntu 18.04 fails

Robin 2018-09-16 11:03:55 UTC in Nimble Streamer
54952af241c6ac79e78761fa827ad323

root@localhost:/etc/apt# apt-get install nimble
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nimble
root@localhost:/etc/apt# apt-get install nimble*
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nimble*
E: Couldn't find any package by glob 'nimble*'
E: Couldn't find any package by regex 'nimble*'

Denis Slobodskoy 2018-09-17 00:02:56 UTC
C723b4e32e1909d3d1b5519f98b586fe

Did you add nimble repository to /etc/apt/sources.list , as it directed?
deb http://nimblestreamer.com/ubuntu bionic/
(notice that it's not a command, it's the line you should add)

Robin 2018-09-17 04:10:14 UTC
54952af241c6ac79e78761fa827ad323

Yes complete procedure is followed.

I am trying to install nimble on Macchiatobin Marvell armada 8040 SBC board which has ARM quad core cpu. 4 GB RAM 64GB eMM running Linux kernel 4.4.52,

When I tried raspbian version it gives dependancy error.

Denis Slobodskoy 2018-09-17 04:44:32 UTC
C723b4e32e1909d3d1b5519f98b586fe

Sorry, only x86_64 version of Ubuntu is supported.
The only ARM Linux supported is Raspbian 8 (Jessie) and 9 (Stretch) : https://wmspanel.com/nimble/install#os_raspbian

Max 2018-09-17 05:34:35 UTC
Ba425406063261ec184229ed0d5a200d

Did you try to add "deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi " line to sources.list along with Nimble repository and install it? What were the errors in this case?

Robin 2018-09-18 06:09:06 UTC
54952af241c6ac79e78761fa827ad323

root@localhost:/# apt-get install nimble
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nimble:armhf : Depends: libjson-c2:armhf (>= 0.10) but it is not installable
Depends: libzip2:armhf (>= 0.10) but it is not installable
E: Unable to correct problems, you have held broken packages.
root@localhost:/#

Max 2018-09-18 07:16:56 UTC
Ba425406063261ec184229ed0d5a200d

Try to search libjson-c2 and libzip2 packages, which versions are available?

Max 2018-09-18 07:18:01 UTC
Ba425406063261ec184229ed0d5a200d

Anyway, we do not "officially" provide packages for Ubuntu 18.04 for ARM (though it may be possible to install Nimble to it installing required dependencies).

Robin 2018-09-18 07:46:45 UTC
54952af241c6ac79e78761fa827ad323

THe problem is not with dependancy it is with version
ARM Nimble is available for "armhf" port wich is 32 bit linux for ARM . while we need Nimble for arm64 port . as per your website
""Nimble is created using C++ programming language and has its own code base with no third-party libraries. This all makes it easy to port to any desirable platform. "" KIndly Port Nimble on arm64.

Post a reply



This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.