Post a new question



auth issue on log file. Incoming rtsp not work

devel2011 2018-09-04 21:36:32 UTC in Nimble Streamer

I have IP-cam Hikvision ds-2cd2722fwd-is. RTSP stream have url: rtsp//admin_user:password@ip_address_cam:554/Streaming/Channels/101.
But, outgoing stream not start, and in log file Nimble Streamer this notice:
created socket s=1016
V: connecting to s=1016 'ip_address_cam:554'
D: rtsp open, s=1016 url=rtsp://ip_address_cam/Streaming/Channels/101
D: getsockopt() fd=564 retval=0 error=0 FD_ISSET(&except_fds)=0
D: getsockopt() fd=1016 retval=0 error=0 FD_ISSET(&except_fds)=0
D: getsockopt() fd=1016 retval=0 error=0 FD_ISSET(&except_fds)=0
E: auth issue on s=1016 stream='nimble_live2/str2'
D: shutdown client s=1016
D: failed to recv from s=1016 (errno=10058)
E: failed to recv buffer from client: 1016
D: rtsp close, s=1016
D: socket s=1016 closed

Incoming stream RTSP, codec H264 - MPEG-4 AVC (part 10) (h264).
In Ip-cam enable setting RTSP Autorisation: digest. I'm change this to dagest/basic, but it's not work too. What i'm doing not right?

devel2011 2018-09-04 21:56:53 UTC

As soon as I asked for help, I saw the problem.
My password ended with an @, and the delimiter is also @.
In the URL line, it was necessary to write the pts: // admin_user: **** @@ ip_address_cam: 554, etc.

devel2011 2018-09-04 21:58:33 UTC

rtsp: // admin_user: **** @@ ip_address_cam: 554, etc.

Post a reply

This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.