Forum

Post a new question

Categories:

Tags:

SSL + Cors .. lost

Thomas 2018-11-15 12:52:33 UTC in Nimble Streamer
Ee7dba0113ba15076c79d0e9043d7718

I have the following config:

port = 8081
ssl_port = 443
ssl_certificate = /etc/letsencrypt/live/(my domain)/cert.pem
ssl_certificate_key = /etc/letsencrypt/live/(my domain)/privkey.pem
access_control_allow_origin = *
access_control_allow_headers = *
access_control_expose_headers = Content-Length

and the short version is that it doesn't work :)

without https, I can stream content properly. What am I missing in the config? Each time a similar question pops up, there is an answer with a link to a 2014 page that doesn't really help.
I have followed the steps here: https://www.svnlabs.com/blogs/wmspanel-nimble-install-ssl-support-for-hls/

Max 2018-11-15 13:03:06 UTC
Ba425406063261ec184229ed0d5a200d

Hello Thomas,

Please provide some more information, what exactly does not work?
Does Nimble start successfully after adding those settings? Did you check nimble.log for errors?

I guess it is not related to CORS headers so you can remove access_control_* options and see the same behavior.

Thomas 2018-11-15 13:16:19 UTC
Ee7dba0113ba15076c79d0e9043d7718

Hi Max,

This got solved.. my partner had decided without telling me anything that somehow it would be a good idea to put cloudflare in front of the stream...

So the config above works! thanks.

Post a reply



This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.