Forum

Post a new question

Categories:

Tags:

Rasberry Pi - Nimble Server Performance

George 2017-02-06 13:39:53 UTC in Nimble Streamer
7a7703fec7f7a010ccb3809366732d28

Hi,
I have installed Nimble Server on Rasberry Pi as per instructions provided on the site.

But I am not even able to play 1 single mp4 video from a Android mobile client. Video stutters a lot, same video when loaded through Nimble on Windows work absolutely fine.

Dashboard of Nimble Streamer show 1% CPU load & 2% RAM load on RPi so its not overburdened. I am unable to figure out whats making it work in such sluggish manner.

Any help would be greatly appreciated...

-Thanks

Yury Udovichenko 2017-02-07 07:59:01 UTC
8926135388643c4be9ec685a7033dc32

Hi,

You say you tried it on Android client. This might be bandwidth issue of your network.
Please try playing it on PC and measure the download speed to compare it to your mobile network capacity.

George 2017-02-07 09:16:20 UTC
7a7703fec7f7a010ccb3809366732d28

Hi Yury,
Thanks for your response, somehow things have improved now. I am able to play on 4 devices without any issue. On adding 5 devices things start to crawl.

[1] Only thing I could notice was that memory of RPi goes upto 921708 of 947732, maybe this is prohibiting more users to gain access. Is there anything that can be done to reduce this memory consumption ?

[2] Is there a Jessie upgrade version ? I have Whizzy at the moment ?

-Thanks

Alex Pokotilo 2017-02-07 09:20:18 UTC
B0af1cee7eb1e40dd284d9982b3aef70

if your PI transmux mp4 -> hls it require enough disk IO and some memory. I'm recommend to increase RAM cache in server settings for prevent Nimble from using your ROM for hls chunk cache.
you can check PI with live stream and same users and if works your problem is in ROM speed for sure

George 2017-02-07 10:35:25 UTC
7a7703fec7f7a010ccb3809366732d28

Hi Yury,
Thanks for your response, I have made the following changes. Retesting now...

#max_cache_size = 64
max_cache_size = 80

#max_disk_cache_size = 4096
max_disk_cache_size = 6000

-Thanks

George 2017-02-07 10:37:40 UTC
7a7703fec7f7a010ccb3809366732d28

For Live stream I do not have Pi Camera yet :(

George 2017-02-07 11:52:15 UTC
7a7703fec7f7a010ccb3809366732d28

Hi Alex,
What I found that if I stop Nimble Streamer service the memory (RAM)is not de-allocated, I have to reboot to that. Could this be the problem resulting in video stuttering after 4 devices ?

-Thanks

George 2017-02-12 17:22:01 UTC
7a7703fec7f7a010ccb3809366732d28

response would be much appreciated, I would suggest keeping paid support option for customers genuinely interested in getting a response asap...

Alex Pokotilo 2017-02-13 01:34:15 UTC
B0af1cee7eb1e40dd284d9982b3aef70

Please increase RAM/ROM cache via gui http://blog.wmspanel.com/2014/01/setting-nimble-caching-gui.html

config method will not work. it's obsolete

George 2017-02-13 18:47:48 UTC
7a7703fec7f7a010ccb3809366732d28

I increased:
[1] Max RAM cache size(MB) from 80 to 320
[2] Max file cache size(MB) from 4000 to 16384

But still Nimble would serve just 6 connections which is the same as with earlier settings, no difference at all :(

George 2017-02-13 18:48:43 UTC
7a7703fec7f7a010ccb3809366732d28

These changes were done from the WMSPanel Web UI, not manually.

Alex Pokotilo 2017-02-14 03:51:24 UTC
B0af1cee7eb1e40dd284d9982b3aef70

Hi,
Nimble will not be able to serve more vod streams on PI then.
Try to use different transmuxer to compare or use server platform for your need.

George 2017-02-14 17:48:04 UTC
7a7703fec7f7a010ccb3809366732d28

Hi Alex,
It was not Nimble problem but Chrome that does not allow more than 6 connection to the same IP. I was able to overcome this and test on Firefox where it served almost 10 connections. Will be doing more stress testing tomorrow...

-Thanks

Post a reply