Forum

Post a new question

Categories:

Tags:

Issue configuring CORS for HTTP and HTTPS streaming with HTML5 players

Josh 2017-05-26 15:04:37 UTC in Nimble Streamer
1b0455bc5ddab36b08d7d70c123b53c7

Hello!

I am currently trying to configure Nimble streamer to work properly with CORS on HTML5 players, but have not been able to get it working so far.

Currently, my nimble.conf file has the following entries for attempting to get it working:

access_control_allow_origin = *
crossdomain_xml_allow_access_from_domain = *
crossdomain_xml = /etc/nimble/crossdomain.xml
access_control_allow_credentials = true
access_control_allow_headers = Range

And additionally I have the following in the /etc/nimble/crossdomain.xml

<?xml version="1.0"?><cross-domain-policy><allow-access-from domain="*" secure="false"/></cross-domain-policy>

I do have SSL configured, with a port defined and recognized in WMSpanel. I am using the certificate for the TLD that I use nimble for.

But so far this has not gotten it working when I try to test HTTP streaming with Bitdash's test player, and HTTPS doesn't load in the preview for the stream within WMSPanel.

Any help I could get I would appreciate in this working! I'm kind of at a roadblock in figuring it out currently

Alex Pokotilo 2017-05-28 12:29:51 UTC
B0af1cee7eb1e40dd284d9982b3aef70

To setup hls please follow http://blog.wmspanel.com/2014/12/ssl-hls-mpeg-dash-icecast-https-support.html

then open your browser developer tools and what's wrong with your Network tab. Check Console tab either

Josh 2017-05-28 13:40:10 UTC
1b0455bc5ddab36b08d7d70c123b53c7

Thank you, I haven't tried combining the certificate into one file. I will do this to see if this helps solve the issue, and get back to this thread :)

Josh 2017-06-04 04:05:05 UTC
1b0455bc5ddab36b08d7d70c123b53c7

Just wanted to let anyone who may wander to this thread know that I fixed my specific issue.

My issue was that I had not added our domain into WMSPanel, and once I did that, and was getting video source address via my TLD over HTTPS instead of my IP, everything worked just fine!

This does work with wss:// and secure SLDP deliver with the new protocol/player for it.

Cheers!

Alex Pokotilo 2017-06-04 05:33:58 UTC
B0af1cee7eb1e40dd284d9982b3aef70

Hi Josh,
what is your impression of SLDP ?

Josh 2017-06-04 13:56:30 UTC
1b0455bc5ddab36b08d7d70c123b53c7

I'm enjoying it quite a bit actually in testing it!

The only real issue I have is that sometimes the video gets... jittery. For lack of a better term. There gets to be a kind of flutter to the video quality that doesn't happen with RTMP or HLS. Been toying on my end when I can to see if there is anything on my end I can do. Currently using XSplit Pro to stream to Nimble.

Besides that, I am really enjoying where this is going! The HTML5 player is super small too, which is just fantastic.

Raj 2017-09-20 20:19:17 UTC
B48d7bf591174284d621b4015a2117e1

We have the same problem. Where do you add the domain in WMSpanel?
Thanks.

Alex Pokotilo 2017-09-21 03:24:23 UTC
B0af1cee7eb1e40dd284d9982b3aef70

Hi,
this thread is about stream preview problem and problem fixed when custom domain was added in server settings.
To do that:
- open server list https://wmspanel.com/server
- chose your server and open it's settings
- find "Manage custom IP/Ports" and click on it
- specify custom domain what wmspanel preview will use when you click stream preview.

If you actually face with different problem or answer is not clear please contact us via https://wmspanel.com/contact

Post a reply