Forum

Post a new question

Categories:

Tags:

IPv6 wmsauth hash match not found

Paul 2018-07-04 15:07:36 UTC in Paywall: WMSAuth and beyond
Eb14adce38c982e3c5ddb32b31369f68

I'm not sure why users on IPv6 cannot view my protected streams..

Their IP does not look correct. My website is behind Cloudflare and I really don't want to disable CF protection.

eu-central-6: we cannot find hash match for ::ffff:81.39.205.3, signature=[12345]
eu-central-6: we cannot find hash match for ::ffff:185.246.103.34, signature=[12345]
origin-eu-1: we cannot find hash match for ::ffff:206.231.121.124, signature=[12345]

Does anybody know what is happening? I am using
code such as:
$ip = $_SERVER['REMOTE_ADDR'];
if (!empty($_SERVER["HTTP_CF_CONNECTING_IP"])) {
$ip = $_SERVER['HTTP_CF_CONNECTING_IP'];
} elseif (!empty($_SERVER['HTTP_X_REAL_IP'])) {
$ip = $_SERVER['HTTP_X_REAL_IP'];
} elseif (!empty($_SERVER['HTTP_CLIENT_IP'])) {
$ip = $_SERVER['HTTP_CLIENT_IP'];
} elseif (!empty($_SERVER['HTTP_X_FORWARDED_FOR'])) {
$ip = $_SERVER['HTTP_X_FORWARDED_FOR'];
$commapos = strrpos($ip, ',');
$ip = trim( substr($ip, $commapos ? $commapos + 1 : 0) );
}

I did enable ipv6 in nimble.conf on all my servers.

Thank you

Max 2018-07-04 15:41:09 UTC
Ba425406063261ec184229ed0d5a200d

Hello Paul,

Please try to set "listen_interfaces" option to nimble.conf specifying exact IPv4 and IPv6 interfaces that Nimble have to use instead of a default "*" value, IPv4 clients will have "normal" addresses in this case.

Thank you.

Post a reply



This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.