Forum

Post a new question

Categories:

Tags:

Hi Guys, Nimble streamer service is quitting randomly

Gary Rose 2019-01-11 09:02:04 UTC in Nimble Streamer

Hi Guys, Nimble is stopping randomly throughout the day, after a service restart all is well again. Can you advise please?
This is the nimble log entry just before the crash/quit:

[2019-01-11 08:42:56 P2060-T2064] [dvrtmux1] I: signal handler: Bus error (7)
[2019-01-11 08:43:54 P6617-T6617] [nimble] I: *** Nimble Streamer v3.5.4-3 started ***

Max 2019-01-11 09:04:48 UTC

Hello Gary,

Please check there is enough space on disk to keep disk cache of specified (limited) size. Also, if you store DVR content on network drive - make sure there are no issues with it - SIGBUG can also happen trying to access file from external storage when it is disconnected.

Thank you.

Gary Rose 2019-01-11 09:19:06 UTC

Hi Max,
Thank you for your amazingly fast reply...
Machine details:
DEll R720 x HexCore 2.6 32GiG Ram Perc H710
OS drives 2 x 1TB raid 1 - available space 862g
Content Drives 6 x 3TB raid 5 - available space 11TB

WMSPanel server config:

OS Ubuntu 16.04 fully up to date
Software version 3.5.4-3
Max Ram Cache 24gb
Current Ram Cache 719mb
Max file Cache 4gb
Current file Cache 0 Bytes

The machine does not use network drives or any external storage
I have included my WMSPanel registered email address on advise from a friend. the Server in question is names Alpha-Nimble

Gary Rose 2019-01-11 10:34:21 UTC

Hi Max,

Can you help further with this please, or give any suggestions where i might look?

Best regards

Max 2019-01-11 11:04:14 UTC

Hello Gary,

I'd suggest to switch nimble logging mode to debug, capture logs after several stoppages and file a ticket via https://wmspanel.com/help providing us logs for analysis.

When did you have this issue for the first time on that server?

Gary Rose 2019-01-11 11:06:35 UTC

Hi Max,

The problem started around 36 hours ago.
I will change log mode and do as you suggest

Thank you for helping
Best regards

Sergey 2019-01-15 10:53:32 UTC

Hi Max.
We have many equal devices with differents version of Nimble at Debian 8 and beginig december 2018 daily found new errors like this only with v 3.5.4-3. After twice errors on single device we switches log to debug mode. Now waiting to catch.

Max 2019-01-15 12:57:04 UTC

Hello Sergey,

Do you also have "signal handler: Bus error" error on your server?

Sergey 2019-01-15 13:05:25 UTC

Yes!
In all situations we have status of service Nimble "active (exited)", but http request /manage/server_status not work and default log [dvrtmux1] I: signal handler: Bus error (7)

Max 2019-01-16 12:11:45 UTC

Hello Sergey,

Please upgrade Nimble to 3.5.4-4, the issue with SIGBUS should be fixed in that release.

Thank you.

Sergey 2019-01-16 12:40:22 UTC

Hi Max.
Ok, will try new version!
Thank you.

Post a reply



This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.