Forum

Post a new question

Categories:

Tags:

FFMPEG : Transcoding

Sergio 2016-03-30 17:57:56 UTC in Nimble Streamer
C29303945999aa72d59e7537f4e53135

Hi,

I'm trying transcoding a live streaming with this code :

/usr/local/bin/ffmpeg -i rtmp://163.172.25.219:1935/test/test -vcodec libx264 -preset veryfast -b:v 2000k -maxrate 2000k -bufsize 2000k -s 1280x720 -sws_flags lanczos -r 60 -acodec copy -f flv rtmp://163.172.25.219:1935/test/test2

But it does not work.

regards,

Yury Udovichenko 2016-03-31 02:11:31 UTC
8926135388643c4be9ec685a7033dc32

Hi,

Please specify what exactly doesn't work - what behavior do you see.
If it's related to Nimble Streamer, please post your question to https://wmspanel.com/help

Joël 2016-04-01 10:45:51 UTC
3b4ac90c74f1f6941223ebab5952e991

Hi,
you need rtmp authentication like:

-f flv "rtmp://ip-nimble-server:1935/application?rtmpauth=user:password/stream"

karwan 2016-04-03 23:24:42 UTC
6502adb482884f9cc2331584593b2c1d

Nimble rtmp authentication

rtmp://user:paaswd@server:1935/live/test

karwan 2016-04-14 20:47:59 UTC
6502adb482884f9cc2331584593b2c1d

Ubuntu 14.04 should be amended as follows

/usr/local/bin/ffmpeg -i
to
ffmpeg -i

Andrey 2018-08-13 09:43:50 UTC
C68284d17d5bc8cbaf014dcb05085ed5

rtmp
I created interface and application with the name "live" login and password also "live"
in ffmpeg rtmp://live:live@ip/live
I get [rtmp @ 0x561816633140] Can not read RTMP handshake response
If I try to use srt then
[srt @ 0x55c5c96b0540] Connection setup failure: connection time out.
srt: //80.85.245.11: 1234: Unknown error occurred
11: 58: 41.143066 / SRT: RcvQ: worker !! FATAL !!: SRT.c: CChannel reported ERROR DURING TRANSMISSION - IPE. INTERRUPTING worker anyway.

Max 2018-08-13 12:17:50 UTC
Ba425406063261ec184229ed0d5a200d

Hello Andrey,

Are you trying to pull or push RTMP stream? What is the full command you're trying to use?

Andrey 2018-08-13 12:36:46 UTC
C68284d17d5bc8cbaf014dcb05085ed5

coder push to nimble
if push mpegts udp there are problems with delays. Coder and Nimble are located in different cities

coder ubuntu
ffmpeg -y -re -i $FILE_INPUT -map 0:v -c:v:0 $VCODEC -vf:v:0 bwdif=0 -r:v:0 25 -maxrate:v:0 300k -bufsize: v:0 300k -b:v:0 300k -s:v:0 640x480 -profile:v:0 main -map 0:v -c:v:1 $VCODEC -vf:v:1 bwdif=0 -r:v:1 25 -maxrate:v:1 600k -bufsize: v:1 600k -b:v:1 600k -s:v:1 1024x768 -profile:v:1 main -map 0:a -c:a:0 $ACODEC -b:a:0 64k -f flv "rtmp://live:live@nimble_ip/live"

In nimble created interface and application with rtmp and name "live" login and password also "live"

Max 2018-08-13 12:39:13 UTC
Ba425406063261ec184229ed0d5a200d

Try to push it without authentication enabled, will it work?

I'd also suggest to try pushing with URL authentication like it described in https://blog.wmspanel.com/2014/07/rtmp-publish-url-authentication.html article.

Andrey 2018-08-13 13:35:55 UTC
C68284d17d5bc8cbaf014dcb05085ed5

in coder
[rtmp @ 0x55745b76bac0] Cannot read RTMP handshake response
rtmp://nimble_ip/live?rtmpauth=live:live/stream: Connection reset by peer

without authentication
Global setting Nimble clear login and password and clear login and password in application "live"

[rtmp @ 0x56021f8c00c0] Cannot read RTMP handshake response
rtmp://nimble_ip/live: Connection reset by peer

Max 2018-08-13 13:37:18 UTC
Ba425406063261ec184229ed0d5a200d

Please check nimble.log on the server, are there any errors?

Andrey 2018-08-13 13:52:55 UTC
C68284d17d5bc8cbaf014dcb05085ed5

No(

Max 2018-08-14 02:46:07 UTC
Ba425406063261ec184229ed0d5a200d

Hello Andrey,

Please file a support ticket via https://wmspanel.com/help form and provide us publish point URL so we could check what is going wrong in your case.

Thank you.

Post a reply



This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.