Cant get FMLE and Nimble Media Streamer to work with Public IPs

vern 2015-12-05 17:57:20 UTC in WMSPanel functionality


I have a pc at home behind a BT Home Hub 5a router with fibre broadband. I've installed FMLE and Nimble Media Streamer on this same PC. Everything works great with private 192.168.x.x addressing.

However, when i try to use the public IP for my PC FMLE cannot connect to the Flash Media Server.

Any suggestions? I've tried messing with the router and adding port forwarding, not sure if i did it right but it still doesnt work.

Joël 2015-12-06 10:38:14 UTC 

Hi Vern,
When the live stream works fine locally. I mean when you can play the live stream from fmle in the wmspanel or with VLC with
http:\\192.168.x.x:8081\live\stream\playlist.m3u8, than the port forwarding is not correct in your router.
for playback open 8081 in the router to your home PC, and port 1935 too, if you want to connect fmle from outside with your Nimble streamer

Vern 2015-12-06 23:11:10 UTC 

Hi Joel,

I got it to work! I had 8081 and 1935 opened on my router. however no joy. So i used a port scanner and saw that those two ports were still blocked.

So i turned off windows firewall and tried the port scanner again. both ports worked.

So then i added my public IP to the player in Nimble and got my smartphone to access the stream and it worked.

Many thanks!

Joël 2015-12-07 06:35:38 UTC 

nice! good luck

Post a reply

Post a new question


This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.