Forum

Post a new question

Categories:

Tags:

Authentication republishing from nimble to wowza

Joël 2016-09-29 14:39:34 UTC in WMSPanel functionality
3b4ac90c74f1f6941223ebab5952e991

Hi,
when I republish an incoming stream to a wowza CDN, with ffmpeg I can use the normal way of authentication:
rtmp://user:pass@wowza_adress:1935/application/stream

When I add a republishing rtmp rule in wmspanel it won't work with one the available authentication method's.

Is there a way to add manual the right authentication?

Alex Pokotilo 2016-09-30 01:31:39 UTC
B0af1cee7eb1e40dd284d9982b3aef70

"rtmp://user:pass" authentication method is Adobe proprietary parented mechanism. Please ask wowza cdn whether they have support for parameter based authorization. If they support such method you will be able to add parameter to either output application or output stream.

Paul 2016-11-07 23:33:40 UTC
4275366b0a4a51a6d926c8e42812653b

Hi. Did you fix it?

for me with FFmpeg -

does not work
rtmp://login:password@ipetc....

works
rtmp://server_ip:1935/live?login:password/streamid

Regards

Alex Pokotilo 2016-11-08 06:38:42 UTC
B0af1cee7eb1e40dd284d9982b3aef70

this issue you report with ffmpeg is different than one initially reported.
Please start new support thread via https://wmspanel.com/contact and provide more info:
- ffmpeg version(I've check with ffmpeg 2.8.8 and above and all works fine)
- Nimble version and if possible test publish point on your server to reproduce a problem

Paul 2016-11-08 07:28:00 UTC
4275366b0a4a51a6d926c8e42812653b

Sorry I misread what Joël said, I was trying to help but now I see it was not ffmpeg problem!

Post a reply