Why nimble using 4 cores on my server?

Nimble 2022-10-09 17:57:23 UTC in WMSPanel functionality

It causes the server to get stuck in a lot of traffic

port = 80
logging = info
worker_threads = 200
max_cache_size = 8004
max_disk_cache_size = 68096
cache_path = /var/cache/nimble
rtmp_worker_threads = 100
transmuxer_threads = 100
chunk_cache_control = max-age=120
playlist_cache_control = max-age=4
http_origin = true
websocket_live_worker_threads = 4

Aleksandr 2022-10-09 18:21:21 UTC 

Your machine provides 16 CPU threads, there is no sense in setting the number of various Nimble's threads to these weird values: "200" or "100", set them to e.g. 8 and take a look how it goes.
After that, to see which thread gets loaded (if it does) enable the per-thread view in htop:
[F2] > "Display options" > activate "Tree view" and "Show custom thread names".
The performance tuning related points are described here:

Amin 2022-10-09 19:00:11 UTC 

Thanks for your help
can i set it to 16?

Aleksandr 2022-10-10 04:40:26 UTC 

Yes, you can try.
If there is a HyperThreading in action, please be aware of this:

Post a reply

Post a new question


This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.