Nimble streamer is not listening on ipv6 port

Jeff B. 2022-11-29 18:49:42 UTC in Nimble Streamer

My internet connection uses Nat'ed (cgnat carrier grade nat) ipv4 addresses, which are not public - so cannot be used to stream from the server.
However, they provide ipv6, and I have it set up and working on the server for ssh, and ftp services. Nimble streamer is not listening on the ipv6 addresses, only ipv4. how can I get it to listen to ipv6?

Aleksandr 2022-11-29 21:25:53 UTC 

To enable IPv6 in Nimble - add the following parameter to /etc/nimble/nimble.conf file:
enable_ipv6 = true
Sometimes, it's also required to define the exact IPv6 addr to bind, adding it to listen_interfaces = <list>, details:
Please restart Nimble service after modifying nimble.conf in order to apply changes.

Jeff B. 2022-11-30 00:47:39 UTC 

Thank you. That did the trick.

Post a reply

Post a new question


This website or its third-party tools use cookies, which are necessary to its functioning and required to achieve the purposes illustrated in the Privacy Policy. If you want to know more or withdraw your consent to all or some of the cookies, please refer to the Privacy Policy.
By closing this banner, scrolling this page, clicking a link or continuing to browse otherwise, you agree to the use of cookies.